Automounter won't start

I get the following error when trying to start automounter:

/usr/sbin/automount: kernel protocol version 5.00 or above required.
Could not start automount

Related tags: Linux

Credit: Original Poster

You probably have both CONFIG_AUTOFS_FS (Kernel automounter support) and CONFIG_AUTOFS4_FS (Kernel automounter version 4 support) enabled in the kernel.
CONFIG_AUTOFS_FS is the old version of automounter and thus not compatible with newer versions of autofs.
Remove CONFIG_AUTOFS_FS and recompile/reboot and automounter should start.

Rating: 2

Propose a different solution...